Adri's Blog

Ein privates Blog

Doch ein Treiber für den ZTE MF637

| 2 Kommentare

Vor einigen Wochen habe ich berichtet, wie man den ZTE MF637 mit Hilfe von usbmodeswitch das UMTS Modem ohne Treiber des Providers nutzen kann. Da ich diesen Stick von T-Mobile habe und er im Produkt web’n’walk Fusion Stick enthalten ist, hat es mich schon sehr geärgert das damals T-Mobile keine Treiber anbot obwohl es explizit auf der Verpackung stand.

Mein Dank geht an Ionic, der mir freundlicherweise den Link zum T-Mobile Treiber gegeben hat. Der Treiber ist leider nur für ein 32 bit(i686) Linux Distribution erhältlich, dabei ist es egal ob es ein Ubuntu, welches die DEB Dateien als Paketverwaltungssystem nutzt, oder eine andere Distribution ist wie OpenSUSE.

Für andere Distributionen steht ein Installationsscript zur Verfügung welches den Treiber ohne große Probleme installieren sollte.

Ich habe aber auf meinem Rechner ein 64Bit(x86_64) Kubuntu am laufen und daher nützt mir der Treiber in gewisser weise nichts. Man kriegt aber durch folgendes auch auf einem 64Bit System installiert.

Für (K)Ubuntu gilt folgendes, öffnet eine Konsole und tippt sudo dpkg –install –force=architecture TMobile_LinuxUI.deb ein. Damit solltet ihr die Probleme seitens der Architektur überbrücken. Für alle anderen Linux Distributionen gilt folgendes, entpackt die Datei Tmobile_LinuxUI.tar.gz und öffnet eine Konsole. Dann tippt ihr folgendes ein, sudo ./install.sh woraufhin sich der Treiber ohne Probleme installieren lässt, egal welche Architektur ihr nutzt.

Wie gesagt, installiert bekommen habe ich den Treiber zwar, aber er will unter 64Bit nicht starten, folgende Fehlermeldung spuckt die Konsole immer aus libqt-mt.so.3 doesn’t exis, was soviel bedeutet das die Bibliothek nicht existiert. Aus mangel an der Zeit fehlt mir die entsprechende Zeit um nach der fehlenden Abhängigkeit zu suchen, wer was weiß kann es gerne berichten ich bin über jede Hilfe dankbar 🙂 aber nichts desto trotz werde ich mich trotzdem weiter um das Problem kümmern 🙂

Stay tuned 😉

Autor: Adrian

Hallo, mein Name ist Adrian. Windows- und Linux-User, Technik affiner Mensch mit faibel zu guten Videospielen. Ich blogge über Thematiken die mich besonders interessieren, welche meist aus der Windows-, Linux- und Android-Welt enstpringen, da mich diese Plattformen seit langem täglich begleiten.

2 Kommentare

  1. Hi,
    ich habe mir den Treiber von Tmobile installiert, komme aber nicht weiter. Installation fehlerfrei, wenn ich das Proggi starte, dann bleibt der im Status Initialisierung stehen. Es poppt eine Dialogbox hoch, in der ich anklicken könnte, dass er mit Tmobile Deutschland verbinden soll. Klicken kann ich aber nicht, die Software steht. In den Logs wird mein Stick immernoch als USB Massenspeicher angegeben.
    Hast Du eine Idee, wo es hängt?
    Gruß,
    Mirco

  2. Hi Mirco,

    hast du die libsub installiert?
    Könnte vielleicht daran liegen, weil die Software von T-Mobile keine abhängigkeiten hat. Da ich selber aber kein 32Bit Ubuntu nutze sondern 64Bit läuft der Treiber bei mir ganz und gar nicht.
    Aber für usb_modeswitch wird ja auch die libusb verlangt damit das Modem vom Datenträger zum Modem geswitcht wird.
    Versuch einfach mal die libusb nach zurüsten im Ubuntu, das kannst du per konsole machen sudo apt-get install libusb oder über das Grafischemenü dort gibste als Suchstichwort nur libusb ein.

    Gruß,
    Adri

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.